GitHub Advisoryadvisory · Maven
GHSA-wxr5-93ph-8wr9 Apache Commons Improper Access Control vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2025-48734
- Ecosystem
- Maven
- Packages
- commons-beanutils:commons-beanutils, org.apache.commons:commons-beanutils2
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-284
- Reviewed
- 2025-05-28
Affected packages
• Maven commons-beanutils:commons-beanutils: >= 1.0, < 1.11.0 → fixed in 1.11.0
• Maven org.apache.commons:commons-beanutils2: >= 2.0.0-M1, < 2.0.0-M2 → fixed in 2.0.0-M2
Description
Improper Access Control vulnerability in Apache Commons.
A special BeanIntrospector class was added in version 1.9.2. This can be used to stop attackers from using the declared class property of Java enum objects to get access to the classloader. However this protection was not enabled by default. PropertyUtilsBean (and consequently BeanUtilsBean) now disallows declared class level property access by default.
Releases 1.11.0 and 2.0.0-M2 address a potential security issue when accessing enum properties in an uncontrolled way. If an application using Commons BeanUtils passes property paths from an external source directly to the getProperty() method of PropertyUtilsBean, an attacker can access the enum’s class loader via the “declaredClass” property available on all Java “enum” objects. Accessing the enum’s “declaredClass” allows remote attackers to access the ClassLoader and execute arbitrary code. The same issue exists with PropertyUtilsBean.getNestedProperty().
Starting in versions 1.11.0 and 2.0.0-M2 a special BeanIntrospector suppresses the “declaredClass” property. Note that this new BeanIntrospector is enabled by default, but you can disable it to regain the old behavior; see section 2.5 of the user's guide and the unit tests.
This issue affects Apache Commons BeanUtils 1.x before 1.11.0, and 2.x before 2.0.0-M2.Users of the artifact commons-beanutils:commons-beanutils
1.x are recommended to upgrade to version 1.11.0, which fixes the issue.
Users of the artifact org.apache.commons:commons-beanutils2
2.x are recommended to upgrade to version 2.0.0-M2, which fixes the issue.
Related
Alias · CVE (1)
- CVE-2025-48734 Improper Access Control vulnerability in Apache Commons. vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-48734 advisory
- https://github.com/apache/commons-beanutils/commit/bd20740da25b69552ddef8523beec0837297eaf9 web
- https://github.com/apache/commons-beanutils package
- https://lists.apache.org/thread/s0hb3jkfj5f3ryx6c57zqtfohb0of1g9 web
- https://lists.debian.org/debian-lts-announce/2025/06/msg00027.html web
- http://www.openwall.com/lists/oss-security/2025/05/28/6 web