GitHub Advisoryadvisory · Packagist

GHSA-wxvf-839f-jqmh Craft CMS Cross site Scripting vulnerability

MEDIUM Published 2022-09-17 Modified 2022-09-20 Official page ↗
Aliases
CVE-2022-37248
Ecosystem
Packagist
Packages
craftcms/cms
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2022-09-20

Affected packages

• Packagist craftcms/cms: >= 4.0.0-RC1, < 4.2.1 → fixed in 4.2.1

Description

Craft CMS 4.2.0.1 is vulnerable to Cross Site Scripting (XSS) via `src/helpers/Cp.php`.

Related

Alias · CVE (1)

  • CVE-2022-37248 Craft CMS 4.2.0.1 is vulnerable to Cross Site Scripting (XSS) via src/helpers/Cp.php. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References