GitHub Advisoryadvisory · Packagist

GHSA-wxxw-5gq6-j2g5 contao/core Insufficient input validation allows for code injection and remote execution

CRITICAL Published 2024-05-15 Modified 2024-05-15 Official page ↗
Ecosystem
Packagist
Packages
contao/core
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
Reviewed
2024-05-15

Affected packages

• Packagist contao/core: >= 2.0.0, < 2.11.17 → fixed in 2.11.17 • Packagist contao/core: >= 3.0.0, < 3.2.9 → fixed in 3.2.9

Description

contao/core versions 2.x prior to 2.11.17 and 3.x prior to 3.2.9 are vulnerable to arbitrary code execution on the server due to insufficient input validation. In fact, attackers can remove or change pathconfig.php by entering a URL, meaning that the entire Contao installation will no longer be accessible or malicious code can be executed.

References