GitHub Advisoryadvisory · PyPI
GHSA-x23q-4j9j-9cxw Ops CLI Deserialization of Untrusted Data vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2021-40720
- Ecosystem
- PyPI
- Packages
- ops-cli
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
- Reviewed
- 2024-04-29
Affected packages
• PyPI ops-cli: < 2.0.5 → fixed in 2.0.5
Description
Ops CLI version 2.0.4 (and earlier) is affected by a Deserialization of Untrusted Data vulnerability to achieve arbitrary code execution when the `checkout_repo` function is called on a maliciously crafted file. An attacker can leverage this to execute arbitrary code on the victim machine.
Related
Alias · CVE (1)
- CVE-2021-40720 Ops CLI version 2.0.4 (and earlier) is affected by a Deserialization of Untrusted Data vulnerability to achieve arbitrary code execution… vulnerability
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness