GitHub Advisoryadvisory · RubyGems

GHSA-x27v-x225-gq8g Recurly gem Server-Side Request Forgery in Resource#find method

CRITICAL Published 2017-12-06 Modified 2023-08-29 Official page ↗
Aliases
CVE-2017-0905
Ecosystem
RubyGems
Packages
recurly
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-918
Reviewed
2020-06-16

Affected packages

• RubyGems recurly: >= 2.3.0, < 2.3.10 → fixed in 2.3.10 • RubyGems recurly: >= 2.2.0, < 2.2.5 → fixed in 2.2.5 • RubyGems recurly: >= 2.1.0, < 2.1.11 → fixed in 2.1.11 • RubyGems recurly: >= 2.0.0, < 2.0.13 → fixed in 2.0.13 • RubyGems recurly: >= 2.9.0, < 2.9.2 → fixed in 2.9.2 • RubyGems recurly: >= 2.8.0, < 2.8.2 → fixed in 2.8.2 • RubyGems recurly: >= 2.7.0, < 2.7.8 → fixed in 2.7.8 • RubyGems recurly: >= 2.6.0, < 2.6.3 → fixed in 2.6.3 • RubyGems recurly: >= 2.5.0, < 2.5.4 → fixed in 2.5.4 • RubyGems recurly: >= 2.4.0, < 2.4.11 → fixed in 2.4.11 • RubyGems recurly: >= 2.11.0, < 2.11.3 → fixed in 2.11.3 • RubyGems recurly: >= 2.10.0, < 2.10.4 → fixed in 2.10.4

Description

The Recurly Client Ruby Library before 2.0.13, 2.1.11, 2.2.5, 2.3.10, 2.4.11, 2.5.4, 2.6.3, 2.7.8, 2.8.2, 2.9.2, 2.10.4, 2.11.3 is vulnerable to a Server-Side Request Forgery vulnerability in the `Resource#find` method that could result in compromise of API keys or other critical resources.

Related

Alias · CVE (1)

  • CVE-2017-0905 The Recurly Client Ruby Library before 2.0.13, 2.1.11, 2.2.5, 2.3.10, 2.4.11, 2.5.4, 2.6.3, 2.7.8, 2.8.2, 2.9.2, 2.10.4, 2.11.3 is… vulnerability

Weakness · CWE (1)

  • CWE-918 Server-Side Request Forgery weakness

References