GitHub Advisoryadvisory · RubyGems
GHSA-x2fr-v8wf-8wwv Ruby-SAML Improper Authentication vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2017-11428
- Ecosystem
- RubyGems
- Packages
- ruby-saml
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- Weaknesses
- CWE-287
- Reviewed
- 2020-06-16
Affected packages
• RubyGems ruby-saml: < 1.7.0 → fixed in 1.7.0
Description
OneLogin Ruby-SAML 1.6.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.
Related
Alias · CVE (1)
- CVE-2017-11428 OneLogin Ruby-SAML 1.6.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that… vulnerability
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness