GitHub Advisoryadvisory · Packagist

GHSA-x2jp-hh65-4xvf Cross-site scripting (XSS) and Server side request forgery (SSRF) in moodle

MEDIUM Published 2021-03-29 Modified 2021-11-18 Official page ↗
Aliases
CVE-2021-20280
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2021-03-24

Affected packages

• Packagist moodle/moodle: >= 3.10, < 3.10.2 → fixed in 3.10.2 • Packagist moodle/moodle: >= 3.9, < 3.9.5 → fixed in 3.9.5 • Packagist moodle/moodle: >= 3.8, < 3.8.8 → fixed in 3.8.8 • Packagist moodle/moodle: >= 3.5, < 3.5.17 → fixed in 3.5.17

Description

Text-based feedback answers required additional sanitizing to prevent stored XSS and blind SSRF risks in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Related

Alias · CVE (1)

  • CVE-2021-20280 Text-based feedback answers required additional sanitizing to prevent stored XSS and blind SSRF risks in moodle before 3.10.2, 3.9.5,… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References