GitHub Advisoryadvisory · npm
GHSA-x2ph-qqwm-9cc6 CleverTap Cordova plugin vulnerable to Cross-site Scripting
CRITICAL
Official page ↗
- Aliases
- CVE-2023-2507
- Ecosystem
- npm
- Packages
- clevertap-cordova
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-07-17
Affected packages
• npm clevertap-cordova: < 2.7.0 → fixed in 2.7.0
Description
CleverTap Cordova Plugin version 2.6.2 allows a remote attacker to execute JavaScript code in any application that is opened via a specially constructed deeplink by an attacker.
This is possible because the plugin does not correctly validate the data coming from the deeplinks before using them.
Related
Alias · CVE (1)
- CVE-2023-2507 CleverTap Cordova Plugin version 2.6.2 allows a remote attacker to execute JavaScript code in any application that is opened via a… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness