GitHub Advisoryadvisory · Maven
GHSA-x2q2-8pwq-fr5r Jenkins allows Bypass of Access Restrictions
MEDIUM
Official page ↗
- Aliases
- CVE-2015-5325
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
- Weaknesses
- CWE-284
- Reviewed
- 2025-03-13
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: < 1.625.2 → fixed in 1.625.2
• Maven org.jenkins-ci.main:jenkins-core: >= 1.626, < 1.638 → fixed in 1.638
Description
Jenkins before 1.638 and LTS before 1.625.2 allow attackers to bypass intended slave-to-master access restrictions by leveraging a JNLP slave. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-3665.
Related
Alias · CVE (1)
- CVE-2015-5325 Jenkins before 1.638 and LTS before 1.625.2 allow attackers to bypass intended slave-to-master access restrictions by leveraging a JNLP… vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-5325 advisory
- https://github.com/jenkinsci/jenkins/commit/054a329c59171ca12ff98f7063ce7fd053ee08bf web
- https://access.redhat.com/errata/RHSA-2016:0070 web
- https://github.com/jenkinsci/jenkins package
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2015-11-11 web
- http://rhn.redhat.com/errata/RHSA-2016-0489.html web