GitHub Advisoryadvisory · Packagist

GHSA-x2q9-r8gm-f657 Drupal Core Access bypass vulnerability

MEDIUM Published 2022-05-24 Modified 2024-04-23 Official page ↗
Aliases
CVE-2020-13667
Ecosystem
Packagist
Packages
drupal/core, drupal/drupal
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-276
Reviewed
2024-04-23

Affected packages

• Packagist drupal/core: >= 8.8.0, < 8.8.10 → fixed in 8.8.10 • Packagist drupal/core: >= 8.9.0, < 8.9.6 → fixed in 8.9.6 • Packagist drupal/core: >= 9.0.0, < 9.0.6 → fixed in 9.0.6 • Packagist drupal/drupal: >= 8.8.0, < 8.8.10 → fixed in 8.8.10 • Packagist drupal/drupal: >= 8.9.0, < 8.9.6 → fixed in 8.9.6 • Packagist drupal/drupal: >= 9.0.0, < 9.0.6 → fixed in 9.0.6

Description

Access bypass vulnerability in of Drupal Core Workspaces allows an attacker to access data without correct permissions. The Workspaces module doesn't sufficiently check access permissions when switching workspaces, leading to an access bypass vulnerability. An attacker might be able to see content before the site owner intends people to see the content. This vulnerability is mitigated by the fact that sites are only vulnerable if they have installed the experimental Workspaces module. This issue affects Drupal Core8.8.X versions prior to 8.8.10; 8.9.X versions prior to 8.9.6; 9.0.X versions prior to 9.0.6.

Related

Alias · CVE (1)

  • CVE-2020-13667 Access bypass vulnerability in of Drupal Core Workspaces allows an attacker to access data without correct permissions. vulnerability

Weakness · CWE (1)

  • CWE-276 Incorrect Default Permissions weakness

References