GitHub Advisoryadvisory · Packagist
GHSA-x2v2-2jhp-c5hv Magento stored cross-site scripting vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2021-36027
- Ecosystem
- Packagist
- Packages
- magento/project-community-edition, magento/community-edition
- Severity
- Moderate
- Weaknesses
- CWE-79
- Reviewed
- 2025-11-06
Affected packages
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
• Packagist magento/community-edition: < 2.3.7-p1 → fixed in 2.3.7-p1
• Packagist magento/community-edition: 2.3.7 (no fix yet)
• Packagist magento/community-edition: >= 2.4.2-p1, < 2.4.2-p2 → fixed in 2.4.2-p2
• Packagist magento/community-edition: 2.4.2 (no fix yet)
Description
Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by a stored cross-site scripting vulnerability that could be abused by an attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
Related
Alias · CVE (1)
- CVE-2021-36027 Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by a stored cross-site scripting… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness