GitHub Advisoryadvisory · Packagist

GHSA-x32v-7qw8-cpq8 Moodle Unauthenticated Access

MEDIUM Published 2022-05-13 Modified 2023-11-02 Official page ↗
Aliases
CVE-2016-8642
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-284
Reviewed
2023-07-28

Affected packages

• Packagist moodle/moodle: >= 3.1.0, < 3.1.3 → fixed in 3.1.3 • Packagist moodle/moodle: >= 3.0.0, < 3.0.7 → fixed in 3.0.7 • Packagist moodle/moodle: >= 2.9.0, < 2.9.9 → fixed in 2.9.9 • Packagist moodle/moodle: >= 2.8.0, <= 2.8.12 (no fix yet) • Packagist moodle/moodle: >= 2.7.0, < 2.7.17 → fixed in 2.7.17

Description

In Moodle 2.x and 3.x, the question engine allows access to files that should not be available.

Related

Alias · CVE (1)

  • CVE-2016-8642 In Moodle 2.x and 3.x, the question engine allows access to files that should not be available. vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References