GitHub Advisoryadvisory · Go
GHSA-x33g-375j-jhf7 Mattermost Server has Improper Authorization for Integration Requests
MEDIUM
Official page ↗
- Aliases
- CVE-2017-18916
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
- Weaknesses
- CWE-284
- Reviewed
- 2026-02-06
Affected packages
• Go github.com/mattermost/mattermost-server: < 3.6.7-0.20170420152529-0968e4079e0a → fixed in 3.6.7-0.20170420152529-0968e4079e0a
• Go github.com/mattermost/mattermost-server: >= 3.7.0, < 3.7.5 → fixed in 3.7.5
• Go github.com/mattermost/mattermost-server: >= 3.8.0, < 3.8.2 → fixed in 3.8.2
Description
An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. API endpoint access control does not honor an integration permission restriction.
Related
Alias · CVE (1)
- CVE-2017-18916 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-18916 advisory
- https://github.com/mattermost/mattermost/commit/0968e4079e0aa670254f3fe3a7248d126e3cf877 web
- https://github.com/mattermost/mattermost/commit/b74e85653660525d351d090a1e1874ae933bcbc8 web
- https://github.com/mattermost/mattermost/commit/fb325cc339eb8d8efb60dbadc48fd38897201c6f web
- https://github.com/mattermost/mattermost package
- https://mattermost.com/security-updates web