GitHub Advisoryadvisory · PyPI

GHSA-x368-4g9h-fvv4 vLLM makes Use of Uninitialized Resource

LOW Published 2026-04-27 Modified 2026-05-06 Official page ↗
Aliases
CVE-2026-7141
Ecosystem
PyPI
Packages
vllm
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-908
Reviewed
2026-05-06

Affected packages

• PyPI vllm: < 0.19.1 → fixed in 0.19.1

Description

A vulnerability was found in vLLM up to 0.19.0. The affected element is the function has_mamba_layers of the file vllm/v1/kv_cache_interface.py of the component KV Block Handler. Performing a manipulation results in uninitialized resource. It is possible to initiate the attack remotely. The attack is considered to have high complexity. The exploitability is described as difficult. The exploit has been made public and could be used. The patch is named 1ad67864c0c20f167929e64c875f5c28e1aad9fd. To fix this issue, it is recommended to deploy a patch.

Related

Alias · CVE (1)

  • CVE-2026-7141 A vulnerability was found in vLLM up to 0.19.0. vulnerability

Weakness · CWE (1)

  • CWE-908 Use of Uninitialized Resource weakness

References