GitHub Advisoryadvisory · Maven

GHSA-x3cq-8f32-5f63 Apache RocketMQ may have remote code execution vulnerability when using update configuration function

CRITICAL Published 2023-07-06 Modified 2025-10-22 Official page ↗
Aliases
CVE-2023-33246
Ecosystem
Maven
Packages
org.apache.rocketmq:rocketmq-broker, org.apache.rocketmq:rocketmq-namesrv, org.apache.rocketmq:rocketmq-controller
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
Weaknesses
CWE-94
Reviewed
2023-07-06

Affected packages

• Maven org.apache.rocketmq:rocketmq-broker: >= 5.0.0, < 5.1.1 → fixed in 5.1.1 • Maven org.apache.rocketmq:rocketmq-namesrv: >= 4.0.0, < 4.9.6 → fixed in 4.9.6 • Maven org.apache.rocketmq:rocketmq-controller: >= 5.0.0, < 5.1.1 → fixed in 5.1.1 • Maven org.apache.rocketmq:rocketmq-namesrv: >= 5.0.0, < 5.1.1 → fixed in 5.1.1

Description

For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution.  Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content.  To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .

Related

Alias · CVE (1)

  • CVE-2023-33246 For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution. vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References