GitHub Advisoryadvisory · Packagist

GHSA-x3jx-5w6m-q2fc Mautic vulnerable to Improper Access Control in UI upgrade process

HIGH Published 2024-09-18 Modified 2025-02-28 Official page ↗
Aliases
CVE-2022-25768
Ecosystem
Packagist
Packages
mautic/core-lib, mautic/core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
Weaknesses
CWE-284, CWE-287, CWE-862
Reviewed
2024-09-18

Affected packages

• Packagist mautic/core-lib: >= 1.1.3, < 4.4.13 → fixed in 4.4.13 • Packagist mautic/core-lib: >= 5.0.0-alpha, < 5.1.1 → fixed in 5.1.1 • Packagist mautic/core: >= 1.1.3, < 4.4.13 → fixed in 4.4.13 • Packagist mautic/core: >= 5.0.0-alpha, < 5.1.1 → fixed in 5.1.1

Description

Impact The logic in place to facilitate the update process via the user interface lacks access control to verify if permission exists to perform the tasks. Prior to this patch being applied it might be possible for an attacker to access the Mautic version number or to execute parts of the upgrade process without permission. As upgrading in the user interface is deprecated, this functionality is no longer required. Patches Upgrade to 4.4.13 or 5.1.1 or later. Workarounds None. For more information If you have any questions or comments about this advisory: • Email us at [email protected]

Related

Alias · CVE (1)

  • CVE-2022-25768 The logic in place to facilitate the update process via the user interface lacks access control to verify if permission exists to perform… vulnerability

Weakness · CWE (3)

  • CWE-284 Improper Access Control weakness
  • CWE-287 Improper Authentication weakness
  • CWE-862 Missing Authorization weakness

References