GitHub Advisoryadvisory · npm
GHSA-x3m3-4wpv-5vgc jrburke requirejs vulnerable to prototype pollution
HIGH
Official page ↗
- Aliases
- CVE-2024-38999
- Ecosystem
- npm
- Packages
- requirejs
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-1321
- Reviewed
- 2024-07-10
Affected packages
• npm requirejs: < 2.3.7 → fixed in 2.3.7
Description
jrburke requirejs v2.3.6 was discovered to contain a prototype pollution via the function `s.contexts._.configure`. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties.
Related
Alias · CVE (1)
- CVE-2024-38999 jrburke requirejs v2.3.6 was discovered to contain a prototype pollution via the function s.contexts._.configure. vulnerability
Weakness · CWE (1)
- CWE-1321 Improperly Controlled Modification of Object Prototype Attributes weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-38999 advisory
- https://github.com/requirejs/r.js/issues/1015 web
- https://github.com/requirejs/requirejs/issues/1854 web
- https://github.com/requirejs/requirejs/pull/1856/commits/ebd7a2ff71473542fa132d0d15c10fb4ed1539e1 web
- https://gist.github.com/mestrtee/9acae342285bd2998fa09ebcb1e6d30a web
- https://github.com/requirejs/r.js package
- https://security.snyk.io/vuln/SNYK-JS-REQUIREJS-5416713 web