GitHub Advisoryadvisory · Maven
GHSA-x3pr-fcgm-wjgc Subversion Plugin stored XSS vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2020-2111
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:subversion
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-07-27
Affected packages
• Maven org.jenkins-ci.plugins:subversion: < 2.13.1 → fixed in 2.13.1
Description
Jenkins Subversion Plugin 2.13.0 and earlier does not escape the error message for the Project Repository Base URL field form validation, resulting in a stored cross-site scripting vulnerability. Subversion Plugin 2.13.1 escapes the affected part of the error message.
Related
Alias · CVE (1)
- CVE-2020-2111 Jenkins Subversion Plugin 2.13.0 and earlier does not escape the error message for the Project Repository Base URL field form validation,… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2111 advisory
- https://github.com/jenkinsci/subversion-plugin/commit/545ca52f6de9af7541621bbea716ead449cd2b98 web
- https://github.com/jenkinsci/subversion-plugin package
- https://jenkins.io/security/advisory/2020-02-12/#SECURITY-1725 web
- http://www.openwall.com/lists/oss-security/2020/02/12/3 web