GitHub Advisoryadvisory · Packagist

GHSA-x3x9-349x-2485 moodle: IDOR in edit/delete RSS feed

MEDIUM Published 2024-11-18 Modified 2024-11-20 Official page ↗
Aliases
CVE-2024-48897
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-285, CWE-863
Reviewed
2024-11-18

Affected packages

• Packagist moodle/moodle: < 4.1.14 → fixed in 4.1.14 • Packagist moodle/moodle: >= 4.2.0, < 4.2.11 → fixed in 4.2.11 • Packagist moodle/moodle: >= 4.3.0, < 4.3.8 → fixed in 4.3.8 • Packagist moodle/moodle: >= 4.4.0, < 4.4.4 → fixed in 4.4.4

Description

A vulnerability was found in Moodle. Additional checks are required to ensure users can only edit or delete RSS feeds that they have permission to modify.

Related

Alias · CVE (1)

Weakness · CWE (2)

  • CWE-285 Improper Authorization weakness
  • CWE-863 Incorrect Authorization weakness

References