GitHub Advisoryadvisory · Packagist
GHSA-x42g-82pp-4v6g Magento SQL injection vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2019-8130
- Ecosystem
- Packagist
- Packages
- magento/community-edition
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-89
- Reviewed
- 2024-05-15
Affected packages
• Packagist magento/community-edition: >= 2.2.0, < 2.2.10 → fixed in 2.2.10
• Packagist magento/community-edition: >= 2.3.0, < 2.3.2-p1 → fixed in 2.3.2-p1
Description
A SQL injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. A user with store manipulation privileges can execute arbitrary SQL queries by getting access to the database connection through group instance in email templates.
Related
Alias · CVE (1)
- CVE-2019-8130 A SQL injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-8130 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8130.yaml web
- https://github.com/magento/magento2 package
- https://web.archive.org/web/20210616202033/https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update web