GitHub Advisoryadvisory · RubyGems

GHSA-x457-cw4h-hq5f JSON gem has Improper Input Validation vulnerability

HIGH Published 2017-10-24 Modified 2023-06-01 Official page ↗
Aliases
CVE-2013-0269
Ecosystem
RubyGems
Packages
json
Severity
High
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• RubyGems json: < 1.5.5 → fixed in 1.5.5 • RubyGems json: >= 1.6.0, < 1.6.8 → fixed in 1.6.8 • RubyGems json: >= 1.7.0, < 1.7.7 → fixed in 1.7.7

Description

The JSON gem before 1.5.5, 1.6.x before 1.6.8, and 1.7.x before 1.7.7 for Ruby allows remote attackers to cause a denial of service (resource consumption) or bypass the mass assignment protection mechanism via a crafted JSON document that triggers the creation of arbitrary Ruby symbols or certain internal objects, as demonstrated by conducting a SQL injection attack against Ruby on Rails, aka "Unsafe Object Creation Vulnerability."

Related

Alias · CVE (1)

  • CVE-2013-0269 The JSON gem before 1.5.5, 1.6.x before 1.6.8, and 1.7.x before 1.7.7 for Ruby allows remote attackers to cause a denial of service… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References