GitHub Advisoryadvisory · NuGet
GHSA-x459-p2rx-f8ff .NET Denial of Service Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2022-21986
- Ecosystem
- NuGet
- Packages
- Microsoft.AspNetCore.App.Runtime.win-x64, Microsoft.AspNetCore.App.Runtime.linux-x64, Microsoft.AspNetCore.App.Runtime.win-x86, Microsoft.AspNetCore.App.Runtime.osx-x64, Microsoft.AspNetCore.App.Runtime.linux-musl-x64, Microsoft.AspNetCore.App.Runtime.linux-arm64, Microsoft.AspNetCore.App.Runtime.linux-arm, Microsoft.AspNetCore.App.Runtime.win-arm64, Microsoft.AspNetCore.App.Runtime.win-arm, Microsoft.AspNetCore.App.Runtime.linux-musl-arm64, Microsoft.AspNetCore.App.Runtime.linux-musl-arm, Microsoft.AspNetCore.App.Runtime.osx-arm64
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Reviewed
- 2022-10-21
Affected packages
• NuGet Microsoft.AspNetCore.App.Runtime.win-x64: >= 5.0.0, < 5.0.14 → fixed in 5.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.linux-x64: >= 5.0.0, < 5.0.14 → fixed in 5.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.win-x86: >= 5.0.0, < 5.0.14 → fixed in 5.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.osx-x64: >= 5.0.0, < 5.0.14 → fixed in 5.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-x64: >= 5.0.0, < 5.0.14 → fixed in 5.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.linux-arm64: >= 5.0.0, < 5.0.14 → fixed in 5.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.linux-arm: >= 5.0.0, < 5.0.14 → fixed in 5.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.win-arm64: >= 5.0.0, < 5.0.14 → fixed in 5.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.win-arm: >= 5.0.0, < 5.0.14 → fixed in 5.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm64: >= 5.0.0, < 5.0.14 → fixed in 5.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm: >= 5.0.0, < 5.0.14 → fixed in 5.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.linux-arm: >= 6.0.0, < 6.0.2 → fixed in 6.0.2
• NuGet Microsoft.AspNetCore.App.Runtime.linux-arm64: >= 6.0.0, < 6.0.2 → fixed in 6.0.2
• NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm: >= 6.0.0, < 6.0.2 → fixed in 6.0.2
• NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm64: >= 6.0.0, < 6.0.2 → fixed in 6.0.2
• NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-x64: >= 6.0.0, < 6.0.2 → fixed in 6.0.2
• NuGet Microsoft.AspNetCore.App.Runtime.linux-x64: >= 6.0.0, < 6.0.2 → fixed in 6.0.2
• NuGet Microsoft.AspNetCore.App.Runtime.osx-arm64: >= 6.0.0, < 6.0.2 → fixed in 6.0.2
• NuGet Microsoft.AspNetCore.App.Runtime.osx-x64: >= 6.0.0, < 6.0.2 → fixed in 6.0.2
• NuGet Microsoft.AspNetCore.App.Runtime.win-arm: >= 6.0.0, < 6.0.2 → fixed in 6.0.2
• NuGet Microsoft.AspNetCore.App.Runtime.win-arm64: >= 6.0.0, < 6.0.2 → fixed in 6.0.2
• NuGet Microsoft.AspNetCore.App.Runtime.win-x64: >= 6.0.0, < 6.0.2 → fixed in 6.0.2
• NuGet Microsoft.AspNetCore.App.Runtime.win-x86: >= 6.0.0, < 6.0.2 → fixed in 6.0.2
Description
Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0 and .NET 5.0. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability.
A Denial of Service vulnerability exists in .NET 6.0 and .NET 5.0 when the Kestrel web server processes certain HTTP/2 and HTTP/3 requests.
Affected Software
• Any .NET 6.0 application running on .NET 6.0.1 or lower.
• Any .NET 5.0 application running on .NET 5.0.13 or lower.
Patches
To fix the issue, please install the latest version of .NET 6.0 or .NET 5.0. If you have installed one or more .NET SDKs through Visual Studio, Visual Studio will prompt you to update Visual Studio, which will also update your .NET SDKs.
• If you're using .NET Core 6.0, you should download and install Runtime 6.0.2 or SDK 6.0.102 (for Visual Studio 2022 v17.1) from https://dotnet.microsoft.com/download/dotnet-core/6.0.
• If you're using .NET 5.0, you should download and install Runtime 5.0.14 or SDK 5.0.114 (for Visual Studio 2019 v16.8) or SDK 5.0.405 (for Visual Studio 2011 v16.11) from https://dotnet.microsoft.com/download/dotnet-core/5.0.
.NET 6.0 and .NET 5.0 updates are also available from Microsoft Update. To access this either type "Check for updates" in your Windows search, or open Settings, choose Update & Security and then click Check for Updates.
Other Details
• Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/207
• An Issue for this can be found at https://github.com/dotnet/aspnetcore/issues/40072
• MSRC details for this can be found at https://msrc.microsoft.com/update-guide/en-US/vulnerability/CVE-2022-21986
Related
Alias · CVE (1)
- CVE-2022-21986 .NET Denial of Service Vulnerability vulnerability
References
- https://github.com/dotnet/aspnetcore/security/advisories/GHSA-x459-p2rx-f8ff web
- https://nvd.nist.gov/vuln/detail/CVE-2022-21986 advisory
- https://github.com/dotnet/announcements/issues/207 web
- https://github.com/dotnet/aspnetcore package
- https://lists.fedoraproject.org/archives/list/[email protected]/message/4HMQOHV7G5TF6OMBN6DNTDOKQQU7KHMM web
- https://lists.fedoraproject.org/archives/list/[email protected]/message/CCTBSBE3PNIMXG6ALX2CQG4ZEH7W3YAT web
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-21986 web
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2022-21986 web