GitHub Advisoryadvisory · Packagist

GHSA-x45j-jq9q-gf3q Moodle makes some user data available before completing second factor with MFA enabled

MEDIUM Published 2025-04-25 Modified 2025-04-25 Official page ↗
Aliases
CVE-2025-3627
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-287
Reviewed
2025-04-25

Affected packages

• Packagist moodle/moodle: >= 4.3.0-beta, < 4.3.12 → fixed in 4.3.12 • Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.8 → fixed in 4.4.8 • Packagist moodle/moodle: >= 4.5.0-beta, < 4.5.4 → fixed in 4.5.4

Description

A security vulnerability was discovered in Moodle that allows some users to access sensitive information about other students before they finish verifying their identities using two-factor authentication (2FA).

Related

Alias · CVE (1)

  • CVE-2025-3627 A security vulnerability was discovered in Moodle that allows some users to access sensitive information about other students before they… vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References