GitHub Advisoryadvisory · RubyGems

GHSA-x485-rhg3-cqr4 Spree Commerce is vulnerable to RCE through Search API

CRITICAL Published 2025-08-20 Modified 2025-12-01 Official page ↗
Aliases
CVE-2011-10026
Ecosystem
RubyGems
Packages
spree, rd_searchlogic
Severity
Critical
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weaknesses
CWE-78, CWE-94
Reviewed
2025-11-26

Affected packages

• RubyGems spree: >= 0.30.0.beta1, < 0.50.0 → fixed in 0.50.0 • RubyGems rd_searchlogic: <= 3.0.1 (no fix yet)

Description

Spreecommerce versions prior to 0.50.x contain a remote command execution vulnerability in the API's search functionality. Improper input sanitation allows attackers to inject arbitrary shell commands via the search[instance_eval] parameter, which is dynamically invoked using Ruby’s send method. This flaw enables unauthenticated attackers to execute commands on the server.

Related

Alias · CVE (1)

  • CVE-2011-10026 Spreecommerce versions prior to 0.50.x contain a remote command execution vulnerability in the API's search functionality. vulnerability

Weakness · CWE (2)

  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness
  • CWE-94 Improper Control of Generation of Code weakness

References