GitHub Advisoryadvisory · npm
GHSA-x48m-gp6r-gp4v Malicious Package in rate-map
CRITICAL
Official page ↗
- Ecosystem
- npm
- Packages
- rate-map
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-506
- Reviewed
- 2020-08-31
Affected packages
• npm rate-map: >= 1.0.3, < 1.0.5 → fixed in 1.0.5
Description
Version 1.0.3 of `rate-map` contains malicious code. The malware breaks functionality of the `purescript-installer` package by rewriting code of the `dl-tar` dependency.
Recommendation
Upgrade to version 1.0.5 or later. There is no indication of further compromise.
Related
Weakness · CWE (1)
- CWE-506 Embedded Malicious Code weakness