GitHub Advisoryadvisory · PyPI, crates.io

GHSA-x4qr-2fvf-3mr5 Vulnerable OpenSSL included in cryptography wheels

HIGH Published 2023-02-08 Modified 2025-11-04 Official page ↗
Aliases
CVE-2023-0286
Ecosystem
PyPI, crates.io
Packages
cryptography, openssl-src
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H
Weaknesses
CWE-843
Reviewed
2023-02-08

Affected packages

• PyPI cryptography: >= 0.8.1, < 39.0.1 → fixed in 39.0.1 • crates.io openssl-src: < 111.25.0 → fixed in 111.25.0 • crates.io openssl-src: >= 300.0.0, < 300.0.12 → fixed in 300.0.12

Description

pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 0.8.1-39.0.0 are vulnerable to a security issue. More details about the vulnerabilities themselves can be found in https://www.openssl.org/news/secadv/20221213.txt and https://www.openssl.org/news/secadv/20230207.txt. If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.

Related

Alias · CVE (1)

  • CVE-2023-0286 There is a type confusion vulnerability relating to X.400 address processing inside an X.509 GeneralName. vulnerability

Weakness · CWE (1)

  • CWE-843 Access of Resource Using Incompatible Type weakness

References