GitHub Advisoryadvisory · npm

GHSA-x5gf-qvw8-r2rm pm2 Regular Expression Denial of Service vulnerability

LOW Published 2025-06-09 Modified 2026-05-20 Official page ↗
Aliases
CVE-2025-5891
Ecosystem
npm
Packages
pm2
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Weaknesses
CWE-1333, CWE-400
Reviewed
2025-06-10

Affected packages

• npm pm2: < 7.0.0 → fixed in 7.0.0

Description

A vulnerability classified as problematic was found in Unitech pm2 prior to 7.0.0. This vulnerability affects unknown code of the file /lib/tools/Config.js. The manipulation leads to inefficient regular expression complexity. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used.

Related

Alias · CVE (1)

  • CVE-2025-5891 A vulnerability classified as problematic was found in Unitech pm2 up to 6.0.6. vulnerability

Weakness · CWE (2)

  • CWE-1333 Inefficient Regular Expression Complexity weakness
  • CWE-400 Uncontrolled Resource Consumption weakness

References