GitHub Advisoryadvisory · Maven
GHSA-x5m7-rwfx-w7qm Remote Code Execution in Apache Flume
HIGH
Official page ↗
- Aliases
- CVE-2022-25167
- Ecosystem
- Maven
- Packages
- org.apache.flume.flume-ng-sources:flume-jms-source
- Severity
- High
- Reviewed
- 2022-06-17
Affected packages
• Maven org.apache.flume.flume-ng-sources:flume-jms-source: >= 1.4.0, < 1.10.0 → fixed in 1.10.0
Description
Apache Flume versions 1.4.0 through 1.9.0 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.
Related
Alias · CVE (1)
- CVE-2022-25167 Apache Flume versions 1.4.0 through 1.9.0 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-25167 advisory
- https://github.com/apache/flume/commit/dafb26ccb172141c6e14e95447e1b6ae38e9a7d0 web
- https://github.com/apache/flume package
- https://issues.apache.org/jira/browse/FLUME-3416 web
- https://lists.apache.org/thread/16nf6b81zjpdc4y93ho99oxo83ddbsvg web
- http://www.openwall.com/lists/oss-security/2022/06/14/1 web