GitHub Advisoryadvisory · Maven
GHSA-x637-x8p3-5p22 Improper Authentication in Spring Authorization Server
MEDIUM
Official page ↗
- Aliases
- CVE-2024-22258
- Ecosystem
- Maven
- Packages
- org.springframework.security:spring-security-oauth2-authorization-server
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-287, CWE-470
- Reviewed
- 2024-03-20
Affected packages
• Maven org.springframework.security:spring-security-oauth2-authorization-server: < 1.1.6 → fixed in 1.1.6
• Maven org.springframework.security:spring-security-oauth2-authorization-server: >= 1.2.0, < 1.2.3 → fixed in 1.2.3
Description
Spring Authorization Server versions 1.0.0 - 1.0.5, 1.1.0 - 1.1.5, 1.2.0 - 1.2.2 and older unsupported versions are susceptible to a PKCE Downgrade Attack for Confidential Clients.
Specifically, an application is vulnerable when a Confidential Client uses PKCE for the Authorization Code Grant.
An application is not vulnerable when a Public Client uses PKCE for the Authorization Code Grant.
Related
Alias · CVE (1)
- CVE-2024-22258 Spring Authorization Server versions 1.0.0 - 1.0.5, 1.1.0 - 1.1.5, 1.2.0 - 1.2.2 and older unsupported versions are susceptible to a PKCE… vulnerability