GitHub Advisoryadvisory · Packagist

GHSA-x684-96hh-833x Craft CMS has a potential RCE with a compromised security key

HIGH Published 2025-01-21 Modified 2025-10-22 Official page ↗
Aliases
CVE-2025-23209
Ecosystem
Packagist
Packages
craftcms/cms
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H/E:H
Weaknesses
CWE-94
Reviewed
2025-01-21

Affected packages

• Packagist craftcms/cms: >= 5.0.0-RC1, < 5.5.8 → fixed in 5.5.8 • Packagist craftcms/cms: >= 4.0.0-RC1, < 4.13.8 → fixed in 4.13.8

Description

Impact This is an RCE vulnerability that affects Craft 4 and 5 installs where your security key has already been compromised. https://craftcms.com/knowledge-base/securing-craft#keep-your-secrets-secret Anyone running an unpatched version of Craft with a compromised security key is affected. Patches This has been patched in Craft 5.5.8 and 4.13.8. Workarounds If you can't update to a patched version, then rotating your security key and ensuring its privacy will help to migitgate the issue. References https://github.com/craftcms/cms/commit/e59e22b30c9dd39e5e2c7fe02c147bcbd004e603

Related

Alias · CVE (1)

  • CVE-2025-23209 Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References