GitHub Advisoryadvisory · npm

GHSA-x6fg-f45m-jf5q Regular Expression Denial of Service in semver

HIGH Published 2017-10-24 Modified 2026-03-03 Official page ↗
Aliases
CVE-2015-8855
Ecosystem
npm
Packages
semver
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-1333
Reviewed
2020-06-16

Affected packages

• npm semver: >= 1.0.4, < 4.3.2 → fixed in 4.3.2

Description

Versions 4.3.1 and earlier of `semver` are affected by a regular expression denial of service vulnerability when extremely long version strings are parsed. Recommendation Update to version 4.3.2 or later

Related

Alias · CVE (1)

  • CVE-2015-8855 The semver package before 4.3.2 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka… vulnerability

Weakness · CWE (1)

  • CWE-1333 Inefficient Regular Expression Complexity weakness

References