GitHub Advisoryadvisory · npm
GHSA-x6wp-rfwh-hcx7 Regular Expression Denial of Service in content
HIGH
Official page ↗
- Aliases
- CVE-2017-16111
- Ecosystem
- npm
- Packages
- content
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
- Reviewed
- 2020-06-16
Affected packages
• npm content: < 3.0.7 → fixed in 3.0.7
Description
Affected versions of `content` are vulnerable to a regular expression denial of service when parsing malicious `Content-Type` and `Content-Disposition` headers.
Recommendation
Update to version 3.0.6 or later.
Related
Alias · CVE (1)
- CVE-2017-16111 The content module is a module to parse HTTP Content-* headers. vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness