GitHub Advisoryadvisory · Packagist

GHSA-x72f-ggjw-v5xh Drupal Core Arbitrary PHP code execution vulnerability

HIGH Published 2022-05-24 Modified 2024-04-23 Official page ↗
Aliases
CVE-2020-13664
Ecosystem
Packagist
Packages
drupal/core, drupal/drupal
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-77
Reviewed
2024-04-23

Affected packages

• Packagist drupal/core: >= 8.8.0, < 8.8.8 → fixed in 8.8.8 • Packagist drupal/core: >= 8.9.0, < 8.9.1 → fixed in 8.9.1 • Packagist drupal/core: >= 9.0.0, < 9.0.1 → fixed in 9.0.1 • Packagist drupal/drupal: >= 8.8.0, < 8.8.8 → fixed in 8.8.8 • Packagist drupal/drupal: >= 8.9.0, < 8.9.1 → fixed in 8.9.1 • Packagist drupal/drupal: >= 9.0.0, < 9.0.1 → fixed in 9.0.1

Description

Arbitrary PHP code execution vulnerability in Drupal Core under certain circumstances. An attacker could trick an administrator into visiting a malicious site that could result in creating a carefully named directory on the file system. With this directory in place, an attacker could attempt to brute force a remote code execution vulnerability. Windows servers are most likely to be affected. This issue affects: Drupal Drupal Core 8.8.x versions prior to 8.8.8; 8.9.x versions prior to 8.9.1; 9.0.1 versions prior to 9.0.1.

Related

Alias · CVE (1)

  • CVE-2020-13664 Arbitrary PHP code execution vulnerability in Drupal Core under certain circumstances. vulnerability

Weakness · CWE (1)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References