GitHub Advisoryadvisory · crates.io
GHSA-x7m9-mv49-fv73 Vaultwarden vulnerable to user impersonation
HIGH
Official page ↗
- Aliases
- CVE-2024-55225
- Ecosystem
- crates.io
- Packages
- vaultwarden
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P
- Weaknesses
- CWE-276, CWE-863
- Reviewed
- 2025-01-09
Affected packages
• crates.io vaultwarden: < 1.32.5 → fixed in 1.32.5
Description
An issue in the component src/api/identity.rs of Vaultwarden prior to v1.32.5 allows attackers to impersonate users, including Administrators, via a crafted authorization request.
Related
Alias · CVE (1)
- CVE-2024-55225 An issue in the component src/api/identity.rs of Vaultwarden prior to v1.32.5 allows attackers to impersonate users, including… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-55225 advisory
- https://github.com/dani-garcia/vaultwarden/commit/20d9e885bfcd7df7828d92c6e59ed5fe7b40a879 web
- https://github.com/dani-garcia/vaultwarden/commit/37c14c3c69b244ec50f5c62b4c9260171607c1d8 web
- https://github.com/dani-garcia/vaultwarden package
- https://github.com/dani-garcia/vaultwarden/releases/tag/1.32.4 web
- https://github.com/dani-garcia/vaultwarden/releases/tag/1.32.5 web
- https://insinuator.net/2024/11/vulnerability-disclosure-authentication-bypass-in-vaultwarden-versions-1-32-5 web