GitHub Advisoryadvisory · PyPI
GHSA-x823-j7c4-vpc5 Cross-site scripting in sickrage
MEDIUM
Official page ↗
- Aliases
- CVE-2021-25926
- Ecosystem
- PyPI
- Packages
- sickrage
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2021-04-13
Affected packages
• PyPI sickrage: >= 9.3.54, < 10.0.11.dev2 → fixed in 10.0.11.dev2
Description
In SiCKRAGE, versions 9.3.54.dev1 to 10.0.11.dev1 are vulnerable to Reflected Cross-Site-Scripting (XSS) due to user input not being validated properly in the `quicksearch` feature. Therefore, an attacker can steal a user's sessionID to masquerade as a victim user, to carry out any actions in the context of the user.
Related
Alias · CVE (1)
- CVE-2021-25926 In SiCKRAGE, versions 9.3.54.dev1 to 10.0.11.dev1 are vulnerable to Reflected Cross-Site-Scripting (XSS) due to user input not being… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness