GitHub Advisoryadvisory · PyPI
GHSA-x8c6-gj59-6rx8 py-libp2p is vulnerable to DoS attacks through use of large RSA keys
MEDIUM
Official page ↗
- Aliases
- CVE-2025-29606
- Ecosystem
- PyPI
- Packages
- libp2p
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-770
- Reviewed
- 2025-07-14
Affected packages
• PyPI libp2p: < 0.2.3 → fixed in 0.2.3
Description
py-libp2p before 0.2.3 allows a peer to cause a denial of service (resource consumption) via a large RSA key.
Related
Alias · CVE (1)
- CVE-2025-29606 py-libp2p before 0.2.3 allows a peer to cause a denial of service (resource consumption) via a large RSA key. vulnerability
Weakness · CWE (1)
- CWE-770 Allocation of Resources Without Limits or Throttling weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-29606 advisory
- https://github.com/libp2p/py-libp2p/issues/526 web
- https://github.com/libp2p/py-libp2p/pull/531/files web
- https://github.com/libp2p/py-libp2p/commit/e150d3153af30530ce61d751bc166e099f1ead7a web
- https://github.com/libp2p/py-libp2p package
- https://github.com/libp2p/py-libp2p/compare/v0.2.2...v0.2.3 web