GitHub Advisoryadvisory · Maven
GHSA-x8q8-4hp5-463w Improper Limitation of a Pathname to a Restricted Directory in Elasticsearch
MEDIUM
Official page ↗
- Aliases
- CVE-2015-3337
- Ecosystem
- Maven
- Packages
- org.elasticsearch:elasticsearch
- Severity
- Moderate
- Weaknesses
- CWE-22
- Reviewed
- 2022-07-06
Affected packages
• Maven org.elasticsearch:elasticsearch: < 1.4.5 → fixed in 1.4.5
• Maven org.elasticsearch:elasticsearch: >= 1.5.0, < 1.5.2 → fixed in 1.5.2
Description
Directory traversal vulnerability in Elasticsearch before 1.4.5 and 1.5.x before 1.5.2, when a site plugin is enabled, allows remote attackers to read arbitrary files via unspecified vectors.
Related
Alias · CVE (1)
- CVE-2015-3337 Directory traversal vulnerability in Elasticsearch before 1.4.5 and 1.5.x before 1.5.2, when a site plugin is enabled, allows remote… vulnerability
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness