GitHub Advisoryadvisory · Go
GHSA-x8qc-fggm-mpqg Ollama contains a heap out-of-bounds read vulnerability in the GGUF model loader
HIGH
Official page ↗
- Aliases
- CVE-2026-7482
- Ecosystem
- Go
- Packages
- github.com/ollama/ollama
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
- Weaknesses
- CWE-125
- Reviewed
- 2026-05-08
Affected packages
• Go github.com/ollama/ollama: < 0.17.1 → fixed in 0.17.1
Description
Ollama before 0.17.1 contains a heap out-of-bounds read vulnerability in the GGUF model loader. The /api/create endpoint accepts an attacker-supplied GGUF file in which the declared tensor offset and size exceed the file's actual length; during quantization in fs/ggml/gguf.go and server/quantization.go (WriteTo()), the server reads past the allocated heap buffer. The leaked memory contents may include environment variables, API keys, system prompts, and concurrent users' conversation data, and can be exfiltrated by uploading the resulting model artifact through the /api/push endpoint to an attacker-controlled registry. The /api/create and /api/push endpoints have no authentication in the upstream distribution. Default deployments bind to 127.0.0.1, but the documented OLLAMA_HOST=0.0.0.0 configuration is widely used in practice (large public-internet exposure observed).
Related
Alias · CVE (1)
- CVE-2026-7482 Ollama before 0.17.1 contains a heap out-of-bounds read vulnerability in the GGUF model loader. vulnerability
Weakness · CWE (1)
- CWE-125 Out-of-bounds Read weakness