GitHub Advisoryadvisory · npm
GHSA-x8rq-rc7x-5fg5 uppy's companion module is vulnerable to Server-Side Request Forgery (SSRF)
HIGH
Official page ↗
- Aliases
- CVE-2022-0086
- Ecosystem
- npm
- Packages
- @uppy/companion
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- Weaknesses
- CWE-918
- Reviewed
- 2022-01-06
Affected packages
• npm @uppy/companion: < 3.1.5 → fixed in 3.1.5
Description
uppy's companion module is vulnerable to Server-Side Request Forgery (SSRF) via IPv4-mapped IPv6 addresses.
Related
Alias · CVE (1)
- CVE-2022-0086 uppy is vulnerable to Server-Side Request Forgery (SSRF) vulnerability
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-0086 advisory
- https://github.com/transloadit/uppy/pull/3403 web
- https://github.com/transloadit/uppy/commit/fc137e30a2a3102eb191141f280d5de20dacdf8f web
- https://github.com/transloadit/uppy web
- https://github.com/transloadit/uppy/releases/tag/uppy%402.3.3 web
- https://huntr.dev/bounties/c1c03ef6-3f18-4976-a9ad-08c251279122 web