GitHub Advisoryadvisory · Packagist

GHSA-x92h-wmg2-6hp7 Invalid HTTP method overrides allow possible XSS or other attacks in Symfony

CRITICAL Published 2019-12-02 Modified 2021-08-19 Official page ↗
Aliases
CVE-2019-10913
Ecosystem
Packagist
Packages
symfony/http-foundation, symfony/symfony
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-79, CWE-89
Reviewed
2019-12-01

Affected packages

• Packagist symfony/http-foundation: >= 2.7.0, < 2.7.51 → fixed in 2.7.51 • Packagist symfony/http-foundation: >= 2.8.0, < 2.8.50 → fixed in 2.8.50 • Packagist symfony/http-foundation: >= 3.0.0, < 3.4.26 → fixed in 3.4.26 • Packagist symfony/http-foundation: >= 4.0.0, < 4.1.12 → fixed in 4.1.12 • Packagist symfony/http-foundation: >= 4.2.0, < 4.2.7 → fixed in 4.2.7 • Packagist symfony/symfony: >= 2.7.0, < 2.7.51 → fixed in 2.7.51 • Packagist symfony/symfony: >= 2.8.0, < 2.8.50 → fixed in 2.8.50 • Packagist symfony/symfony: >= 3.0.0, < 3.4.26 → fixed in 3.4.26 • Packagist symfony/symfony: >= 4.0.0, < 4.1.12 → fixed in 4.1.12 • Packagist symfony/symfony: >= 4.2.0, < 4.2.7 → fixed in 4.2.7

Description

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, HTTP Methods provided as verbs or using the override header may be treated as trusted input, but they are not validated, possibly causing SQL injection or XSS. This is related to symfony/http-foundation.

Related

Alias · CVE (1)

  • CVE-2019-10913 In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, HTTP Methods provided as verbs… vulnerability

Weakness · CWE (2)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness
  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References