GitHub Advisoryadvisory · Packagist

GHSA-x95x-f4g9-mm85 Magento Improper Access Control vulnerability

HIGH Published 2022-08-17 Modified 2024-01-11 Official page ↗
Aliases
CVE-2022-34255
Ecosystem
Packagist
Packages
magento/community-edition
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-284, CWE-863
Reviewed
2024-01-11

Affected packages

• Packagist magento/community-edition: >= 2.3.0, < 2.3.7-p4 → fixed in 2.3.7-p4 • Packagist magento/community-edition: >= 2.4.4, < 2.4.5 → fixed in 2.4.5 • Packagist magento/community-edition: >= 2.4.0, < 2.4.3-p3 → fixed in 2.4.3-p3

Description

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control vulnerability that could result in Privilege escalation. An attacker with a low privilege account could leverage this vulnerability to perform an account takeover for a victim. Exploitation of this issue does not require user interaction.

Related

Alias · CVE (1)

  • CVE-2022-34255 Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control… vulnerability

Weakness · CWE (2)

  • CWE-284 Improper Access Control weakness
  • CWE-863 Incorrect Authorization weakness

References