GitHub Advisoryadvisory · npm

GHSA-x9gp-vjh6-3wv6 CKEditor 5 cross-site scripting (XSS) vulnerability in the clipboard package

LOW Published 2025-09-03 Modified 2025-09-04 Official page ↗
Aliases
CVE-2025-58064
Ecosystem
npm
Packages
ckeditor5, @ckeditor/ckeditor5-clipboard
Severity
Low
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N
Weaknesses
CWE-79
Reviewed
2025-09-03

Affected packages

• npm ckeditor5: >= 46.0.0, < 46.0.3 → fixed in 46.0.3 • npm @ckeditor/ckeditor5-clipboard: >= 44.2.0, < 45.2.2 → fixed in 45.2.2 • npm ckeditor5: >= 44.2.0, < 45.2.2 → fixed in 45.2.2 • npm @ckeditor/ckeditor5-clipboard: >= 46.0.0, < 46.0.3 → fixed in 46.0.3

Description

Impact A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects only installations where the editor configuration meets one of the following criteria: • HTML embed plugin is enabled • Custom plugin introducing editable element which implements view `RawElement` is enabled Patches The problem has been recognized and patched. The fix will be available in version 46.0.3 (and above), and explicitly in version 45.2.2. For more information Email us at [email protected] if you have any questions or comments about this advisory.

Related

Alias · CVE (1)

  • CVE-2025-58064 CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References