GitHub Advisoryadvisory · Maven
GHSA-x9rg-q5fx-fx66 Improper Input Validation in libpam4j
MEDIUM
Official page ↗
- Aliases
- CVE-2017-12197
- Ecosystem
- Maven
- Packages
- org.kohsuke:libpam4j
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2022-07-01
Affected packages
• Maven org.kohsuke:libpam4j: < 1.10 → fixed in 1.10
Description
It was found that libpam4j prior to 1.10 did not properly validate user accounts when authenticating. A user with a valid password for a disabled account would be able to bypass security restrictions and possibly access sensitive information.
Related
Alias · CVE (1)
- CVE-2017-12197 It was found that libpam4j up to and including 1.8 did not properly validate user accounts when authenticating. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-12197 advisory
- https://github.com/kohsuke/libpam4j/issues/18 web
- https://github.com/kohsuke/libpam4j/commit/02ffdff218283629ba4a902e7fe2fd44646abc21 web
- https://access.redhat.com/errata/RHSA-2017:2904 web
- https://access.redhat.com/errata/RHSA-2017:2905 web
- https://access.redhat.com/errata/RHSA-2017:2906 web
- https://bugzilla.redhat.com/show_bug.cgi?id=1503103 web
- https://github.com/kohsuke/libpam4j package
- https://lists.debian.org/debian-lts-announce/2017/11/msg00008.html web
- https://www.debian.org/security/2017/dsa-4025 web