GitHub Advisoryadvisory · Maven

GHSA-xcrm-qpp8-hcw4 Moderate severity vulnerability that affects org.apache.struts:struts2-rest-plugin

MEDIUM Published 2018-10-16 Modified 2021-09-21 Official page ↗
Aliases
CVE-2017-15707
Ecosystem
Maven
Packages
org.apache.struts:struts2-rest-plugin
Severity
Moderate
CVSS vector
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• Maven org.apache.struts:struts2-rest-plugin: >= 2.5.0, < 2.5.16 → fixed in 2.5.16

Description

In Apache Struts 2.5 to 2.5.14, the REST Plugin is using an outdated JSON-lib library which is vulnerable and allow perform a DoS attack using malicious request with specially crafted JSON payload.

Related

Alias · CVE (1)

  • CVE-2017-15707 In Apache Struts 2.5 to 2.5.14, the REST Plugin is using an outdated JSON-lib library which is vulnerable and allow perform a DoS attack… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References