GitHub Advisoryadvisory · NuGet

GHSA-xcvr-qv8h-m7xw .NET Core Denial of Service Vulnerability

HIGH Published 2022-05-13 Modified 2022-10-25 Official page ↗
Aliases
CVE-2018-0875
Ecosystem
NuGet
Packages
Microsoft.NETCore.Jit
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Reviewed
2022-10-25

Affected packages

• NuGet Microsoft.NETCore.Jit: >= 2.0.0, < 2.0.6 → fixed in 2.0.6 • NuGet Microsoft.NETCore.Jit: >= 1.1.0, < 1.1.7 → fixed in 1.1.7 • NuGet Microsoft.NETCore.Jit: < 1.0.12 → fixed in 1.0.12

Description

.NET Core 1.0, .NET Core 1.1, NET Core 2.0 and PowerShell Core 6.0.0 allow a denial of Service vulnerability due to how specially crafted requests are handled, aka ".NET Core Denial of Service Vulnerability".

Related

Alias · CVE (1)

  • CVE-2018-0875 .NET Core 1.0, .NET Core 1.1, NET Core 2.0 and PowerShell Core 6.0.0 allow a denial of Service vulnerability due to how specially crafted… vulnerability

References