GitHub Advisoryadvisory · npm

GHSA-xf94-h87h-g9wr QuestDB UI's Web Console is Vulnerable to Cross-Site Scripting

LOW Published 2026-01-10 Modified 2026-01-13 Official page ↗
Aliases
CVE-2026-0824
Ecosystem
npm
Packages
@questdb/web-console
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
Weaknesses
CWE-79
Reviewed
2026-01-13

Affected packages

• npm @questdb/web-console: < 1.1.10 → fixed in 1.1.10

Description

A security flaw has been discovered in questdb ui up to 1.11.9. Impacted is an unknown function of the component Web Console. The manipulation results in cross site scripting. The attack can be executed remotely. The exploit has been released to the public and may be used for attacks. Upgrading to version 1.1.10 is recommended to address this issue. The patch is identified as b42fd9f18476d844ae181a10a249e003dafb823d. You should upgrade the affected component. The vendor confirmed early that the fix "is going to be released as a part of QuestDB 9.3.0" as well.

Related

Alias · CVE (1)

  • CVE-2026-0824 A security flaw has been discovered in questdb ui up to 1.11.9. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References