GitHub Advisoryadvisory · npm
GHSA-xfg5-vrmc-24wc Obsidian Dataview vulnerable to code injection due to unsafe eval
HIGH
Official page ↗
- Aliases
- CVE-2021-42057
- Ecosystem
- npm
- Packages
- obsidian-dataview
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2023-10-19
Affected packages
• npm obsidian-dataview: < 0.4.13 → fixed in 0.4.13
Description
Obsidian Dataview through 0.4.12-hotfix1 allows eval injection. The `evalInContext` function in executes user input, which allows an attacker to craft malicious Markdown files that will execute arbitrary code once opened. NOTE: 0.4.13 provides a mitigation for some use cases.
Related
Alias · CVE (1)
- CVE-2021-42057 Obsidian Dataview through 0.4.12-hotfix1 allows eval injection. vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness