GitHub Advisoryadvisory · Go
GHSA-xfq9-hh5x-xfq9 Mattermost Fails to Enforce Proper Access Controls on `/api/v4/audits` Endpoint
LOW
Official page ↗
- Aliases
- CVE-2025-24866
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2025-04-11
Affected packages
• Go github.com/mattermost/mattermost/server/v8: >= 9.11.0, < 9.11.9 → fixed in 9.11.9
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20250204211032-f52e08754c49 → fixed in 8.0.0-20250204211032-f52e08754c49
Description
Mattermost versions 9.11.x <= 9.11.8 fail to enforce proper access controls on the /api/v4/audits endpoint, allowing users with delegated granular administration roles who lack access to Compliance Monitoring to retrieve User Activity Logs.
Related
Alias · CVE (1)
- CVE-2025-24866 Mattermost versions 9.11.x <= 9.11.8 fail to enforce proper access controls on the /api/v4/audits endpoint, allowing users with delegated… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness