GitHub Advisoryadvisory · Packagist

GHSA-xfv7-h2qg-rjm7 Moodle Lesson activity password bypass through PHP loose comparison

MEDIUM Published 2024-11-20 Modified 2024-11-20 Official page ↗
Aliases
CVE-2024-45691
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-285, CWE-289
Reviewed
2024-11-20

Affected packages

• Packagist moodle/moodle: < 4.1.13 → fixed in 4.1.13 • Packagist moodle/moodle: >= 4.2.0-beta, < 4.2.10 → fixed in 4.2.10 • Packagist moodle/moodle: >= 4.3.0-beta, < 4.3.7 → fixed in 4.3.7 • Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.3 → fixed in 4.4.3

Description

A flaw was found in Moodle. When restricting access to a lesson activity with a password, certain passwords could be bypassed or less secure due to a loose comparison in the password-checking logic. This issue only affected passwords set to "magic hash" values.

Related

Alias · CVE (1)

Weakness · CWE (2)

  • CWE-285 Improper Authorization weakness
  • CWE-289 Authentication Bypass by Alternate Name weakness

References