GitHub Advisoryadvisory · Packagist
GHSA-xgfm-992v-h2hr Magento vulnerable to denial of service
HIGH
Official page ↗
- Aliases
- CVE-2025-49554
- Ecosystem
- Packagist
- Packages
- magento/project-community-edition, magento/community-edition
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2025-10-21
Affected packages
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
• Packagist magento/community-edition: >= 2.4.9-alpha1, < 2.4.9-alpha2 → fixed in 2.4.9-alpha2
• Packagist magento/community-edition: >= 2.4.8-beta1, < 2.4.8-p2 → fixed in 2.4.8-p2
• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p7 → fixed in 2.4.7-p7
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p12 → fixed in 2.4.6-p12
• Packagist magento/community-edition: < 2.4.5-p14 → fixed in 2.4.5-p14
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/community-edition: 2.4.7 (no fix yet)
• Packagist magento/community-edition: 2.4.8 (no fix yet)
Description
Magento versions 2.4.9-alpha1, 2.4.8-p1, 2.4.7-p6, 2.4.6-p11, 2.4.5-p13, 2.4.4-p14 and earlier are affected by an Improper Input Validation vulnerability that could lead to application denial-of-service. An attacker could exploit this vulnerability by providing specially crafted input, causing the application to crash or become unresponsive. Exploitation of this issue does not require user interaction.
Related
Alias · CVE (1)
- CVE-2025-49554 Adobe Commerce versions 2.4.9-alpha1, 2.4.8-p1, 2.4.7-p6, 2.4.6-p11, 2.4.5-p13, 2.4.4-p14 and earlier are affected by an Improper Input… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness